All systems operational

There is currently a problem with the telephony provider Peoplefone

Resolved
Operational
Started 2 months ago Lasted about 5 hours

Affected

External cloud services
Peoplefone-VOIP-Provider
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Outgoing phone calls are currently affected.
    The problem is known to the provider and is being dealt with as quickly as possible.