All systems operational

The telephony provider Peoplefone is currently experiencing a disruption

Resolved
Operational
Started 19 days ago Lasted about 1 hour

Affected

External cloud services
Peoplefone-VOIP-Provider
Updates
  • Resolved
    Resolved

    The bug has been fixed by Peoplefone.

  • Identified
    Identified

    Currently, incoming calls are only possible to a limited extent. Peoplefone is working hard on a solution